Habilitar interface Wireless cuando esta bloqueada por Hardware

4 comments
Buenas la semana pasada andaba hablando en mil idiomas porque mi pc no funcionaba de manera correcta, ya saben como me pongo los que me conocen el primer problema que tuve fue el no conectarme por wifi desde hace 2 dias atras, por lo cual estaba a punto de dar un grito al cielo, me acorde del uso de rfkill desde mis tiempos con Ubuntu pero para mi sorpresa no funcionaba ni atras ni adelante siempre dandome el siguiente resultado.


Lo raro, fue que en Ubuntu y Debian me furulaba debidamente el uso de rfkill mas  de una vez lo hice, y funcionó porque no daba npi, sera porque Manjaro no es para mi?

Comenze a buzear en google y cada resultado loco que veia, desde uno simple quitar la bateria, esperar un momento y walla funcionara esta solución fue dada para las laptops Dell, como la mia lo es, lo hize no negare lo hize! y nada, otros decian problemas de la BIOS entra y configura que solo funcione con f2 sin usar fn+f2 ok, les hice caso y al final nada de nada!, ya estaba a minutos, digo segundos de llegar a casa  y hacer un hard reset xD me entienden a que me refiero.

Entonces ya por tomar la medida mas loca, decidi hacer lo mas tonto o bobo por decirlo asi probar con wlan0 y demas en una de esas pueden ver en la siguiente captura:



Por arte de magia funciono!, entonces aqui viene mi pregunta retórica al hacer el unblock 0, porque no funcionaba pero si al realizar rfkill unblock wlan.

Así que al realizar ello pude solucionar de manera satisfactoria mi problema, esto no anda de más por si me vuelve a ocurrir o a alguien le pasa.

Regards,
Snifer


4 comentarios

  1. Tamnbien me a pasado con mi portatil. Asta el momento solo ah funcionado con distros en Debian, ni Arch, ni manjaro, ni Xubuntu dan resultado con rfkill, la solucion que de casualidad encontre despues de tragrarme medio Google, fue ni mas ni menos que suspender el equipo y encenderlo y todo vuelve a funcionar. Un saludo. @josecrp92

    ResponderEliminar
    Respuestas
    1. @josecrp92, hice tambien la prueba lo que indicas y ni aun asi respondia el condenado en estos dias me paso lo mismo y tuve que seguir el proceso aqui especificado.

      Espero haya alguna solucion .

      Regards,
      Snifer

      Eliminar
    2. Pues a mi asta el momento es la unica solucion que me daba resultados, al final lo que hice fue incluir los driver de athk9. Un saludo Josecrp92

      Eliminar
    3. La verdad no hice la prueba con los drivers athk9 tuviera que verlo y daria mi opinión pero ya tenemos otra posible solución mas :).


      Regards,
      Snifer

      Eliminar